ANTAL.OM

Se fler Excelfunktioner

Se även: | ANTAL.OMF | ANTAL | ANTALV | ANTAL.TOMMA |

Sammanfattning

ANTAL.OM är en Excelfunktion som räknar antalet celler i ett område som uppfyller ett enskilt villkor. ANTAL.OM kan användas för att räkna celler som innehåller datum, tal och text. De villkor som används i ANTAL.OM stöder logiska operatorer (>,<,<>,=) samt jokertecken (*,?) för delvis matchning.

Syfte
Räkna antalet celler som uppfyller ett givet villkor

Argument
område – Det cellområde vars celler ska räknas
villkor – Det villkor som styr vilka celler som ska räknas.

Returvärde
Ett tal som representerar antalet celler

Syntax
=ANTAL.OM(område;villkor)

Den här lektionen och många andra finner man i Learnesys grundkurs Excelkurs Bas!


Exempel 1 – Grundläggande exempel

I exemplet nedan används följande formler i cellerna C4:

=ANTAL.OM(B7:B14;”<10”)

Alla celler som har ett värde över 10 räknas i funktionen, och antalet visas i formelcellen.

Vanligtvis måste textvärden omges av dubbla citattecken (“”), inte enstaka talvärden. Men som vi ser ovan, när en logisk operator finns i samband ett tal måste både talet och operatorn vara inom i citattecken.

Exempel 2 – Värde från en annan cell

Ett värde från en annan cell kan vara med i ett villkor med hjälp av sammanfogning. I exemplet nedan returnerar ANTAL.OM antalet värden i B7:B14 som är mindre än värdet i cell B14. Märk att operatorn ”>” (som är text) är inom i citattecken.

=ANTAL.OM(B7:B14;">"&B14)

räknar antalet celler mindre än B14

Exempel 3 – Inte lika med

Vill du skapa ett villkor för “inte lika med” använder du operatorn “<>” inom citattecken (“”). Till exempel, formeln nedan räknar celler som inte är lika med “blå” i cellområdet B1:B10:

=ANTAL.OM(B1:B10;"<>blå")

Exempel 4 – Tomma celler

ANTAL.OM kan räkna både celler som är tomma eller som inte är tomma. Formlerna nedan räknar tomma respektive inte tomma celler i området B1:B10:

=ANTAL.OM(B1:B10;"<>") 

räknar inte tomma celler.

=ANTAL.OM(B1:B10;"")

räknar tomma celler.

Exempel 5 – Datum

Det enklaste sättet att använda ANTAL.OM med datum är att sätta in en referens till ett giltigt datum i en annan cell. Om du till exempel vill räkna celler i B1:B10 som innehåller ett datum som är mindre än datumet i C1 skulle man kunna använda denna formel:

=ANTAL.OM(B1:B10; "<"&C1)

räknar antalet datum större än C1.

Notera att vi måste sammanfoga en operatör till datumet i C1. Om du vill använda mer avancerade datumvillkor (tex. alla datum i en viss månad eller alla datum mellan två givna datum) kan du i stället använda funktionen ANTAL.OMF.

Det stadigaste sättet att hårdkoda ett datum till ANTAL.OM är att använda DATUM-funktionen. Detta säkerställer att Excel förstår att värdet är ett datum. Vill du räkna celler i B1:B10 som innehåller ett datum som är mindre än den 1 januari 2021 kan du använda en formel som den här

=ANTAL.OM(B1:B10;"<"&DATUM(2021;1;1))

som räknar antalet datum mindre än 1 januari 2021.

Exempel 6 – ELLER logik

ANTAL.OM är utformad för att endast använda ett enstaka villkor. Men om du vill räkna antalet celler som innehåller ett givet värde eller ett annat kan du använda en matriskonstant och SUMMA-funktion på detta vis:

=SUMMA(ANTAL.OM(cellområde;{"gul","röd"}))

Formeln räknar antalet celler i området som innehåller antingen “gul” eller “röd”. ANTAL.OM returnerar två beräkningar inom en matris (en för “gul” och en för “röd”) och SUMMA-funktionen returnerar summan.

Mer om funktionen ANTAL.OM

ANTAL.OM-funktionen i Excel räknar antalet celler i ett område som uppfyller ett givet villkor. Villkor kan använda logiska operatorer (>,<,<>,=) samt jokertecken (*,?) för delvis matchning. Villkor kan också anknytas till ett värde från en annan cell.

ANTAL.OM är en av åtta funktioner i Excel som delar upp logiska villkor i två delar (cellområde + villkor). Därför är syntaxen som används för att skapa villkor annorlunda, och ANTAL.OM kräver ett cellområde. Man kan alltså inte använda en matris.

ANTAL.OM kan endast använda ett enstaka villkor. Behöver du tillämpa flera villkor kan du i stället använda funktionen ANTAL.OMF. Behöver du modifiera värden i argumentet för cellområdet som en del av ett logiskt test kan du använda funktionerna PRODUKTSUMMA eller FILTER.

Bra att veta om funktionen ANTAL.OM

  • ANTAL.OM är inte skiftlägeskänsligt. Använd funktionen EXAKT för skiftlägeskänsliga räkningar.
  • ANTAL.OM stöder endast ett villkor. Använd funktionen ANTAL.OMF för flera villkor.
  • Textsträngar inom villkor måste vara inom citattecken (“”), dvs.  “äpple”, “>32”, osv.
  • Cellreferenser i villkor använder inte citattecken.
  • ANTAL.OM kräver ett cellområde – man kan inte använda en matris.
  • ANTAL.OM returnerar ett #VÄRDEFEL! när du refererar till en annan arbetsbok som har stängts ner.

Mer läsning

Man lär sig mer om SUMMA-funktionen i våra kurser Excelkurs Bas och Excelfunktioner Fördjupning!

  • Lär dig mer om funktioner genom att registrera dig på vår onlinekurs Praktiska Exceltips. Den är dessutom helt gratis!
  • Har du en fråga eller vill lära dig mer om funktionen? Besök då vårt forum eller vår resursbank.
  • Vill du har fler Exceltips? På Learnesys blogg hittar du massvis av tips! Eller, prenumerera på vårt nyhetsbrev.
  • Till våra kurssidor →

Funktionen ANTAL.OM räknar antalet celler i ett cellområde baserat på ett villkor.

Till exempel kan vi räkna hur många celler innehåller värden högre än tio.

ANTAL.OM funktionen har två argument: Cellområdet… och villkoret.

I vårt exempel markerar vi vårt cellområde… och skriver in ”större än 10” inom citationstecken.

Vi ser att det finns fyra celler i området som är större än tio.

I denna lektion har vi gått igenom ANTAL.OM funktionen, som räknar antalet celler baserat på ett villkor.