ANTAL.OM

Tillbaka till alla funktioner

ANTAL.OM är en Excelfunktion som räknar antalet celler i ett område som uppfyller ett enskilt villkor. ANTAL.OM kan användas för att räkna celler som innehåller datum, tal och text. De villkor som används i ANTAL.OM stöder logiska operatorer (>,<,<>,=) samt jokertecken (*,?) för delvis matchning.

Ändamål

Räkna antalet celler som uppfyller ett givet villkor

Returvärde

Ett tal som representerar antalet celler.

Syntax

=ANTAL.OM(cellområde;villkor)

Argument

cellområde – Det cellområde vars celler ska räknas.

villkor – Det villkor som styr vilka celler som ska räknas.

Användningsanteckningar

ANTAL.OM-funktionen i Excel räknar antalet celler i ett område som uppfyller ett givet villkor. Villkor kan använda logiska operatorer (>,<,<>,=) samt jokertecken (*,?) för delvis matchning. Villkor kan också anknytas till ett värde från en annan cell.

ANTAL.OM är en av åtta funktioner i Excel som delar upp logiska villkor i två delar (cellområde + villkor). Därför är syntaxen som används för att skapa villkor annorlunda, och ANTAL.OM kräver ett cellområde. Man kan alltså inte använda en matris.

ANTAL.OM kan endast använda ett enstaka villkor. Behöver du tillämpa flera villkor kan du i stället använda funktionen ANTAL.OMF. Behöver du modifiera värden i argumentet för cellområdet som en del av ett logiskt test kan du använda funktionerna PRODUKTSUMMA eller FILTER.

Grundläggande exempel

I exemplet nedan används följande formler i cellerna C4:

=ANTAL.OM(B7:B14;”<10”)

Alla celler som har ett värde över 10 räknas i funktionen, och antalet visas i formelcellen.

Vanligtvis måste textvärden omges av dubbla citattecken (””), inte enstaka talvärden. Men som vi ser ovan, när en logisk operator finns i samband ett tal måste både talet och operatorn vara inom i citattecken.

Värde från en annan cell

Ett värde från en annan cell kan vara med i ett villkor med hjälp av sammanfogning. I exemplet nedan returnerar ANTAL.OM antalet värden i B7:B14 som är mindre än värdet i cell B14. Märk att operatorn ”>” (som är text) är inom i citattecken.

=ANTAL.OM(B7:B14;”>”&B14)

Räknar antalet celler mindre än B14

Inte lika med

Vill du skapa ett villkor för ”inte lika med” använder du operatorn ”<>” inom citattecken (””). Till exempel, formeln nedan räknar celler som inte är lika med ”blå” i cellområdet B1:B10:

=ANTAL.OM(B1:B10;”<>blå”)

Tomma celler

ANTAL.OM kan räkna både celler som är tomma eller som inte är tomma. Formlerna nedan räknar tomma respektive  inte tomma celler i området B1:B10:

=COUNTIF(B1:B10,”<>”)

Räknar inte tomma celler

=COUNTIF(B1:B10,””)

Räknar tomma celler

Datum

Det enklaste sättet att använda ANTAL.OM med datum är att sätta in en referens till ett giltigt datum i en annan cell. Om du till exempel vill räkna celler i B1:B10 som innehåller ett datum som är mindre än datumet i C1 skulle man kunna använda denna formel:

=ANTAL.OM(B1:B10; ”<”&C1)

Räknar antalet datum större än C1

Notera att vi måste sammanfoga en operatör till datumet i C1. Om du vill använda mer avancerade datumvillkor (tex. alla datum i en viss månad eller alla datum mellan två givna datum) kan du i stället använda funktionen ANTAL.OMF.

Det stadigaste sättet att hårdkoda ett datum till ANTAL.OM är att använda DATUM- funktionen. Detta säkerställer att Excel förstår att värdet är ett datum. Vill du räkna celler i B1:B10 som innehåller ett datum som är mindre än den 1 januari 2021 kan du använda en formel som den här

=ANTAL.OM(B1:B10;”<”&DATUM(2021,1,1))

Räknar antalet datum mindre än 1 januari 2021

ELLER logik

ANTAL.OM är utformad för att endast använda ett enstaka villkor. Men om du vill räkna antalet celler som innehåller ett givet värde eller ett annat kan du använda en matriskonstant och SUMMA-funktion på detta vis:

=SUMMA(ANTAL.OM(cellområde;{”gul”,”röd”}))

Formeln räknar antalet celler i området som innehåller antingen ”gul” eller ”röd”. ANTAL.OM returnerar två beräkningar inom en matris (en för ”gul” och en för ”röd”) och SUMMA-funktionen returnerar summan.

Anteckningar

  • ANTAL.OM är inte skiftlägeskänsligt. Använd funktionen EXAKT för skiftlägeskänsliga räkningar.
  • ANTAL.OM stöder endast ett villkor. Använd funktionen ANTAL.OMF för flera villkor.
  • Textsträngar inom villkor måste vara inom citattecken (””), dvs.  ”äpple”, ”>32”, osv.
  • Cellreferenser i villkor använder inte citattecken
  • ANTAL.OM kräver ett cellområde – man kan inte använda en matris.
  • ANTAL.OM returnerar ett #VÄRDEFEL! när du refererar till en annan arbetsbok som har stängts ner.

Funktionen ANTAL.OM räknar antalet celler i ett cellområde baserat på ett villkor.

Till exempel kan vi räkna hur många celler innehåller värden högre än tio.

ANTAL.OM funktionen har två argument: Cellområdet… och villkoret.

I vårt exempel markerar vi vårt cellområde… och skriver in ”större än 10” inom citationstecken.

Vi ser att det finns fyra celler i området som är större än tio.

I denna lektion har vi gått igenom ANTAL.OM funktionen, som räknar antalet celler baserat på ett villkor.

Populära kurser

Gratis Excelkurs

Excel på en timme!

Vår kurs Excel på en timme är en gratiskurs för dig som snabbt vill gå från nybörjare till att behärska vardagliga Excelutmaningar....

Excelkurs Bas

Allt du behöver kunna om Excel i en kurs

Excelkurs Bas är Learnesys populära grundkurs i Excel. Detta är en omfattande kurs som riktar sig till den som är...

Excelfunktioner Fördjupning

Lär dig över 100 användbara Excelfunktioner

Lär dig att på ett effektivt sätt hantera databaser, rensa text i celler och hämta in värden från andra tabeller....

Pivottabeller Fördjupning

Analysera data i Excel med Pivottabeller

Du lär dig snabbt och effektivt att sätta upp och analysera databaser. När du väl kan analysera data på en...

Vi hjälper dig att välja rätt onlinekurser för företaget

SQL Bas

Lär dig grunderna och mera i SQL och MySQL

SQL är standardspråk för att kommunicera med en databas som använder sig av en SQL-server. Med SQL kan man hämta,...

Power BI Bas

Skapa dashboards och analysera data med PowerBI

Skapa dynamiska rapporter och visualiseringar över stora mängder data med hjälp av DAX-formler. I kursen skapas en fullständig rapport från...

Power Pivot och DAX

Power Pivot och DAX-formler i Excel

Med Power Pivot och DAX kan du modellera data, visualisera stordata samt enkelt och effektivt göra analyser för att få viktiga insikter. DAX (Data Analysis...

Power Query Bas

Lär dig hämta och omvandla data med Power Query

Power Query – eller Hämta och transformera – är Excels datahanteringsverktyg. Bland annat används Power Query för att importera, bearbeta...

Vi hjälper dig att välja rätt onlinekurser för företaget

Yrkesinriktade kurser

Excel för ekonomer

En anpassad Excelkurs för dig som är ekonom

Excel är ett användbart verktyg, i synnerhet för dig som jobbar inom ekonomi. Vi har därför skapat en unik och...

Excel för inköpare & logistiker

En yrkesanpassad kurs i Excel för dig inom inköp och logistik

Därför har vi tillsammans med branschorganisationer och verksamma i rollen tagit fram en Excelkurs som är anpassad för dig som...

Excel för säljare

Lyft ditt säljresultat med Excel

Lär dig de mest relevanta delarna i Excel på ett tidseffektivt sätt. Fyll i kunskapsluckorna och förhindra onödiga flaskhalsar. Lär...

Oftast fungerar våra kurser bra som dom är, men ibland kan det vara värt att specialanpassa en kurs. Kontakta oss så berättar vi mer.

Kontakta oss