ANTALL.HVIS

Back to all functions

ANTALL.HVIS

ANTALL.HVIS er en Excel-funksjon som teller antall celler i et område som oppfyller en individuell betingelse. ANTALL.HVIS kan brukes til å telle celler som inneholder dato, tall og tekst. Betingelsene som brukes i ANTALL.HVIS støtter logiske operatorer (>, <, <>, =) og jokertegn (* ,?) for delvis samsvar.

Hensikt

Tell antall celler som oppfyller en gitt betingelse

Returverdi

Et tall som representerer antall celler.

Syntaks

= ANTALL.HVIS (celleområde; betingelse)

Argument

celleområde – celleområdet hvis celler skal telles.

betingelse- Betingelsen som styrer hvilke celler som skal telles.

Bruksnotater

ANTALL.HVIS-funksjonen i Excel teller antall celler i et område som oppfyller en gitt betingelse. Termer kan bruke logiske operatorer (>, <, <>, =) og jokertegn (* ,?) for delvis samsvar. Betingelser kan også knyttes til en verdi fra en annen celle.

ANTALL.HVIS er en av åtte funksjoner i Excel som deler logiske betingelser i to deler (celleområde + betingelser). Derfor er syntaksen som brukes til å lage betingelser annerledes, og ANTALL.HVIS krever et celleområde. Så du kan ikke bruke en matrise.

ANTALL.HVIS kan bare bruke én enkelt betingelse. Hvis du må bruke flere betingelser, kan du i stedet bruke funksjonen ANTALL.HVIS.SETT. Hvis du trenger å endre verdier i celleområdeargumentet som en del av en logisk test, kan du bruke funksjonene SUMMERPRODUKT eller FILTER.

Grunnleggende eksempel

I eksemplet nedenfor brukes følgende formler i celle C4:

antall.hvis excel

=ANTALL.HVIS(B7:B14;”<10”)

Alle celler som har en verdi over 10 telles i funksjonen, og tallet vises i formelcellen.

Vanligvis må tekst verdier være omgitt av doble anførselstegn («»), ikke enkle numeriske verdier. Men som vi ser ovenfor, når en logisk operator er knyttet til et tall, må både nummeret og operatoren stå i anførselstegn.

Verdi fra en annen celle

En verdi fra en annen celle kan inkluderes i en betingelse ved å bli med. I eksemplet nedenfor returnerer ANTALL.HVIS antall verdier i B7: B14 som er mindre enn verdien i celle B14. Merk at operatoren «>» (som er tekst) er innenfor anførselstegn.

Antall.om excel

=ANTAL.OM(B7:B14;»>»&B14)

Teller antall celler mindre enn B14

Ikke lik

Hvis du vil opprette en betingelse for «ikke lik», bruk operatoren «<>» innenfor anførselstegn («»). For eksempel teller formelen nedenfor celler som ikke er lik «blå» i celleområdet B1: B10:

= ANTALL.HVIS (B1: B10; «<> blå»)

Tomme celler

ANTALL.HVIS kan telle både celler som er tomme eller som ikke er tomme. Formlene nedenfor beregner tomme og ikke-tomme celler i området B1: B10:

= ANTALL:HVIS(B1: B10, «<>»)

Teller ikke tomme celler

= ANTALL.HVIS(B1: B10,»»)

Teller tomme celler

Dato

Den enkleste måten å bruke ANTALL.HVIS med datoer er å sette inn en referanse til en gyldig dato i en annen celle. For eksempel, hvis du vil telle celler i B1: B10 som inneholder en dato som er mindre enn datoen i C1, kan du bruke denne formelen:

= ANTALL.HVIS(B1:B10;»<«&C1)

Teller antall datoer større enn C1

Merk at vi må slå sammen en operatør til datoen i C1. Hvis du ønsker å bruke mer avanserte datobetingelser (f.eks. alle datoer i en gitt måned eller alle datoer mellom to gitte datoer), kan du bruke funksjonen ANTALL.HVIS.SETT i stedet.

Den mest stabile måten å hardkode en dato til NUMBER.OM er å bruke DATO-funksjonen. Dette sikrer at Excel forstår at verdien er en dato. Hvis du vil telle celler i B1: B10 som inneholder en dato som er mindre enn 1. januar 2021, kan du bruke en formel som denne

= ANTALL.HVIS(B1: B10;»<«&DATO(2021,1,1))

Teller antall datoer mindre enn 1. januar 2021

ELLER logikk

ANTALL.HVIS er designet for å bruke kun én enkelt betingelse. Men hvis du vil telle antall celler som inneholder en gitt verdi eller en annen, kan du bruke en matrisekonstant og SUMMER-funksjon på denne måten:

= SUMMER(ANTALL.HVIS(celleområde;{«gul»,»rød»}))

Formelen teller antall celler i området som inneholder enten «gul» eller «rød». ANTALL.HVIS returnerer to beregninger innenfor en matrise (en for «gul» og en for «rød») og SUMMER-funksjonen returnerer summen.

Notater

• ANTALL.HVIS skiller ikke mellom store og små bokstaver. Bruk EKSAKT-funksjonen for store og små bokstaver.

• ANTALL.HVIS støtter bare én betingelse. Bruk ANTALL.HVIS.SETT-funksjonen for flere forhold.

• Tekststrenger innenfor betingelser må være innenfor anførselstegn («»), dvs. «eple»,»> 32″, osv.

• Betingede cellereferanser bruker ikke anførselstegn

• ANTALL.HVIS krever et celleområde – du kan ikke bruke en matrise.

• ANTALL.HVIS returnerer #VERDIFEIL! når det refereres til en annen arbeidsbok som har blitt stengt.

Funksjonen ANTALL.HVIS teller antall celler som i et celleområde oppfyller ett bestemt vilkår.
Vi kan for eksempel telle hvor mange celler som inneholder en verdi høyere enn ti.

ANTALL.HVIS-funksjonen har to argumenter: Celleområdet … og vilkåret.

I vårt eksempel markerer vi celleområdet …. Og oppgir «større enn 10» i anførselstegn.
Resultatet som blir returnert er at det er fire celler som er større enn ti.

I denne leksjonen har vi sett på ANTALL.HVIS-funksjonen, som teller antall celler basert på ett vilkår.

Populære kurs

Gratiskurs – Introduksjon til Excel

Kostnadsfri introduksjon til Excel

Usikker på om nettbasert læring er rett? Det er nettopp derfor vi har laget dette kurset. Vi har håndplukket relevante...

Pivottabeller Fordypning

Bli ekspert på Excels mest grunnleggende analyseverktøy

Du lærer raskt og effektivt å sette opp og analysere databaser. Når du kan analysere data på et dypere nivå,...

Power BI Basis

Lær deg bruke Power BI og ta datadrevne beslutninger for din virksomhet

Power BI er Microsofts tjeneste innen business intelligence. Business intelligence handler om å analysere og oppsummere data for å skape...

Excelfunksjoner Fordypning

Fordyp å utvikle dine kunnskaper i Excelfunksjoner

Lær hvordan du effektivt administrerer databaser, fjerner tekst i celler og henter verdier fra andre tabeller. Kurset går også gjennom...

Katri

Vi hjelper deg å velge de rette nettkursene for din virksomhet

Power Query Basis

Lær hvordan du henter og konverterer data med Power Query

I onlinekurset Power Query Basis lærer du deg programmet fra grunnen av. Kurset henvender seg til deg som har grunnleggende...

Power BI Basis

Lær deg bruke Power BI og ta datadrevne beslutninger for din virksomhet

Power BI er Microsofts tjeneste innen business intelligence. Business intelligence handler om å analysere og oppsummere data for å skape...

Katri

Vi hjelper deg å velge de rette nettkursene for din virksomhet

Faglige Excelkurs

Excel for økonomer

Et tilpasset Excelkurs for deg som er økonom

Excel er et nyttig verktøy, særlig for deg som jobber innen økonomi. Vi har derfor laget et unikt og tilpasset...

Excel for selgere

Løft salgsresultatene dine med Excel

Lær de mest relevante delene av Excel på en tidseffektiv måte. Dekk kunnskapshullene og forhindre unødvendige flaskehalser. Lær om Pivottabeller,...

Vanligvis fungerer kursene våre som de er, men noen ganger kan det lønne seg å tilpasse et kurs for din organisasjon. Kontakt oss så forteller vi mer.

Kontakt oss