SUMMA-funktionen

Se fler Excelfunktioner

Se även: | SUMMA.OM | SUMMA.OMF | PRODUKTSUMMA |

Sammanfattning

SUMMA-funktion i Excel returnerar summan av angivna värden. Dessa värden kan vara tal, cellreferenser, intervall, matriser och konstanter – i valfri kombination. SUMMA kan hantera upp till 255 individuella argument.

Syfte
Addera tal

Argument
tal1 – första värdet att summera
[tal2] – [valfritt] andra värdet att summera
[tal3] – [valfritt] tredje värdet att summera

Returvärde
Summan av de angivna värdena

Syntax
=SUMMA(tal1, [tal2], [tal3], …)

Den här lektionen och många andra finner man i Learnesys fördjupningskurs i Excel, Excelfunktioner Fördjupning!

Hur använder man SUMMA-funktionen i Excel?

Exempel 1 – SUMMA-funktionen i sin enklaste form

Nedan ses ett exempel på en SUMMA-funktion i sin enklaste form. Normalt används SUMMA-funktionen med intervall. Vad som SUMMA-funktionen gör i det här fallet är att summera alla tal i intervallet C3 till F3.

Bild som visar hur man använder SUMMA-funktionen i Excel.
Exempel 1: SUMMA-funktionen i sin enklaste form.

Notera här att man istället för att ange ett intervall, även kan skriva:

=SUMMA(C3;D3;E3;F3)
=SUMMA(C3:D3;E3:F3)

vilket kommer ge samma resultat.

Exempel 2 – en formel med SUMMA och UNIK

Nedan visas ett exempel på hur man summerar endast unika värden. Formeln består av två funktioner – SUMMA och UNIK.
I cell B15 summeras alla tal med en enkel SUMMA-formel. I cell B16 summeras endast de unika talen, det vill säga delmängden {1, 2, 4, 5, 6, 7, 8}.

En Excel-formel som visar hur man kombinerar funktionerna SUMMA och UNIK.
Exempel 2: formeln använder sig av SUMMA och UNIK för att endast räkna ut de unika talen.

Mer om funktionen SUMMA

SUMMA-funktionen tar emot flera argument med syntax tal1, tal2, tal3, … , tal255. Argumentet kan vara en hårdkodad konstant (ett tal), en cellreferens eller ett intervall.
Alla tal i de angivna argumenten summeras. SUMMA-funktionen ignorerar automatiskt tomma celler och textvärden, varför SUMMA är användbart för att summera celler som kan innehålla textvärden.
SUMMA-funktionen summerar hårdkodade värden och tal som är resultatet av formler. Om du behöver summera ett intervall och ignorera befintliga delsummor, se funktionen DELSUMMA.

Kortkommando

För SUMMA-funktionen finns det även ett kortkommando. Markera den cell eller det intervall där värdena skall summeras. Tryck sedan på Alt + Shift + =. Värdena kommer då summeras automatiskt i den valda cellen eller det valda intervallet.

Bra att veta om SUMMA-funktionen

  • SUMMA ignorerar automatiskt tomma celler och celler med textvärden.
  • Om något argument innehåller fel kommer SUMMA att returnera ett fel.
  • SUMMA.OM-funktionen i Excel returnerar summan av celler som uppfyller ett enda villkor.
  • SUMMA.OMF-funktionen summerar ihop värdena i ett cellområde baserat på flera villkor på en och samma gång.

Mer läsning

Man lär sig mer om SUMMA-funktionen i våra kurser Excelkurs Bas och Excelfunktioner Fördjupning!

  • SUMMA-funktionen används med absoluta eller relativa cellreferenser. Se därför denna artikel.
  • Har du en fråga eller vill lära dig mer om funktionen? Besök då vårt forum eller vår resursbank.
  • Vill du har fler Exceltips? På Learnesys blogg hittar du massvis av tips! Eller, prenumerera på vårt nyhetsbrev.
  • Till våra kurssidor →