OMFEL

Se fler Excelfunktioner

Sammanfattning

OMFEL-funktionen i Excel returnerar ett anpassat resultat när en funktion eller formel genererar ett fel. Om inget fel upptäcks, kommer OMFEL-funktionen att returnera resultatet av den inkapslade funktionen eller formeln. OMFEL är en nyare variant av funktionen ÄRFEL.
OMFEL är ett bra sätt att hantera fel på, istället för att använda en nästlad formel med flera OM-funktioner.

Syfte
Fånga upp och hantera fel

Argument
värde – värdet, referensen eller formeln som ska kontrolleras efter ett fel
värde_om_fel – värdet som ska returneras om ett fel hittas.

Returvärde
Den inkapslade funktionen eller formeln, eller ett felmeddelande om ett fel upptäcks

Syntax
=OMFEL(värde, värde_om_fel)

Den här lektionen och många andra finner man i Learnesys fördjupningskurs i Excel, Excelfunktioner Fördjupning!

Hur använder man OMFEL-funktionen i Excel?

Exempel 1

Om A1 innehåller värdet 2, B1 är tom och C1 innehåller formeln =A1/B1, kommer följande formel att fånga felet #DIVISION/0! som blir resultatet av att dividera A1 med B1.

=OMFEL(A1/B1;"Fyll i ett värde i B1")

När B1 är tom kommer C1 att visa meddelandet “Fyll i ett värde i B1” om B1 är tom eller noll. När ett tal skrivs in i B1 kommer formeln att returnera resultatet av A1/B1.

Exempel 2

Exemplet nedan visar en kombinerad LETARAD– och PASSA-funktion, inkapslad av OMFEL:

Exempel 2: ett exempel som kombinerar funktionerna PASSA, LETARAD och OMFEL, där OMFEL returnerar “SAKNAS” om kundnumret i den högra matrisen inte har någon match i den vänstra.

Vi vill “förena” matriserna till vänster och höger genom att använda att söka efter kundnumret, och sedan förena matriserna på namn. Detta gör vi med funktionerna LETARAD och PASSA. Vi omsluter sedan formeln med en OMFEL-funktion som returnerar “SAKNAS” om formeln hittar något kundnummer i den högra matrisen som inte har en match i den vänstra.


Mer om funktionen OMFEL

Funktionen OMFEL används för att fånga upp fel och returnera ett anpassat resultat, eller ett användarvänligt och pedagogiskt meddelande när ett fel upptäcks. När en formel returnerar ett felfritt resultat returnerar OMFEL det resultatet – OMFEL-funktionen märks inte av i dessa fall och har ingen påverkan på returvärdet. När en formel returnerar ett fel returnerar OMFEL ett anpassat resultat, t ex ett vänligt meddelande som ber användaren att verifiera sina beräkningar. OMFEL är ett bra sätt att fånga och hantera fel, och används numera istället för funktionen ÄRFEL.

OMFEL eller OMSAKNAS

OMFEL-funktionen är en användbar funktion, men dess styrka är även dess svaghet då den kommer fånga många typer av fel. Om det till exempel finns ett stavfel i en formel kommer Excel returnera #NAMN? fel, men OMFEL kommer att “tysta” felet och returnera det alternativa resultatet. Detta kan dölja ett viktigt problem.
I många fall är det mer meningsfullt att använda OMSAKNAS-funktionen, som bara fångar #SAKNAS!-felet.

Bra att veta

  • Det finns fler funktioner i Excel för att hantera fel där OMSAKNAS och ÄRFEL är ytterligare två exempel.
  • Om första argumentet värde är tom, utvärderas det som en tom sträng (“”) och inte ett fel.
  • Om andra argumentet värde_om_fel behandlas som en tom sträng (“”), visas inget meddelande när ett fel upptäcks.

Mer läsning

Man lär sig mer om OMFEL-funktionen i våra kurser Excelkurs Bas och Excelfunktioner Fördjupning!