OM-funktionen

Tillbaka till alla funktioner

M-funktionen kör ett logiskt test, och returnerar ett värde för ett SANT resultat och ett annat för ett FALSKT resultat. Till exempel, för att ”godkänna” poäng över 60 i en OM-funktion ser ut såhär: =OM(A1>60;”Godkänt”;”Underkänt”). Mer än ett villkor kan testas genom att använda fler OM-satser i en funktion. OM kan kombineras med logiska funktioner som OCH och ELLER för att utvidga det logiska testet.

Ändamål

Testa för ett specifikt tillstånd

Returvärde

De värden som förknippar till tillståndet SANT eller FALSKT

Syntax

=OM (logiskt_test; [värde_om_sant]; [värde_om_falskt])

Argument

logiskt_test – Ett värde eller ett logiskt uttryck som kan utvärderas som SANT eller FALSKT.

värde_om_sant – [valfritt] Värdet som ska returneras när logiskt_test utvärderas som SANT.

värde_om_falskt – [valfritt] Värdet som ska returneras när logiskt_test utvärderas som FALSKT.

Användningsanteckningar

OM-funktionen kör ett logiskt test på ett påstående och returnerar olika värden beroende på om resultatet av testet är SANT eller FALSKT. Det första argumentet, logiskt_test, är ett uttryck som returnerar antingen SANT eller FALSKT. Både värde_om_sant och värde_om_falskt är valfria argument, men åtminstone en av dem måste anges. Resultatet från OM kan bli ett värde, en cellreferens eller till och med en helt separat formel.

I exemplet vi gav tidigare ville vi ge antingen ”Godkänt” eller ”Underkänt” baserat på poäng. Godkänt är 60 poäng eller mer. Formeln för detta är:

=OM(C6>=60;”Godkänt”;”Underkänt”)

Detta betyder: Om värdet i cell C6 är större än eller lika med 60, returnera ”Godkänt”. Annars returneras ”Underkänt”.

Det logiska flödet i formeln kan också omvändas. Denna formel returnerar alltså samma resultat:

=OM(C6<60;”Underkänt”;”Godkänt”)

Detta betyder: Om värdet i cell C6 är mindre än 60 returnerar du ”Underkänt”. Annars returneras ”Godkänt”.

Båda formlerna returnerar korrekta resultat när de kopieras nedåt.

Flera OM-satser

OM-funktionen kan ”kapslas”. Med ”kapslade” OM funktioner menar vi en formel där minst en OM-funktion sitter inuti en annan för att testa för fler påståenden samtidigt och returnera fler möjliga resultat. Var OM-sats måste vara noggrant placerad inuti en annan så att logiken är rätt.

Den följande formeln kan till exempel användas för att ge ett resultat från 0-4 i stället för ett resultat för godkänt/underkänt resultat:

=OM(C6<60;”0″;OM(C6<75;”1″;OM(C6<85;”2″;OM(C6<95;”3″;”4″)))

Totalt 64 OM-funktioner kan finnas i samma funktion. Normalt bör du dock tänka på att använda andra funktioner, som till exempel LETARAD eller LETAKOLUMN för mer invecklade scenarier, eftersom de kan behandla fler villkor på ett mycket smidigare sätt.

Logiska operatorer

När du skapar ett logiskt test med en OM-funktion kan du använda någon av följande logiska operatorer:

JämförelseoperatorBetydelseExempel
=lika medA1=B1
större änA1>B1
>=större än eller lika medA1>=B1
mindre änA1<B1
<=mindre än eller lika medA1<=B1
<> inte lika medA1<>B1

OM med OCH, ELLER, ICKE

OM-funktionen kan kopplas samman med funktionerna OCH, ELLER och ICKE. Om du vill till exempel returnera ”Godkänt” när B1 är mellan 1 och 10 skulle du kunna använda denna formel:

=OM(OCH(B1>1;B1<10);”Godkänt”;””)

Detta betyder: Om B1 är större än 1 och mindre än 10, returnera ”Godkänt”. Annars returneras ingenting (””).

För att returnera C1+10 när B1 är antingen ”15” eller ”20” kan du använda funktionen ELLER så här:

=OM(ELLER(B1=”15″;B1=”20″);C1+10;C1)

Detta betyder: Om B1 är antingen 15 eller 20, returnera C1+10. Annars returneras C1.

=OM(ICKE(B1=”15″);B1+10;B1)

Detta betyder: Om B1 INTE är 15, returnera C1+10. Annars returnera C1.

Anteckningar

  • Om du vill villkorligt räkna antalet värden använder du funktionerna ANTAL.OM eller ANTAL.OMF.
  • Om du vill villkorligt summera värden använder du funktionerna SUMMA.OM eller SUMMA.OMF.
  • Om något av de angivna argumenten i OM-funktionen är en matris utvärderas varje enhet i matrisen separat.

Nu kommer vi att gå igenom OM-funktionen, som kollar om ett visst villkor har blivit uppfyllt, och returnerar ett värde beroende på om villkoret är SANT eller FALSKT.

OM-funktionen har tre argument: Villkoret, returvärdet om villkoret är Sant, och returvärdet om villkoret är Falskt.

Till exempel kan vi kolla om värdet i cell B7 är större eller mindre än 50.
Vi skriver in Lika med, OM, B7 är större än 50.

Vi vill ha ett S om villkoret är sant, och ett F om det är falskt.

Resultatet är att värdet i B7 är mindre än 50, så returvärdet blir F.

Om vi kopierar neråt kan vi kolla om värdet i B8 är större än 50, vilket vi ser är sant.
I denna lektion har vi gått igenom den väldigt användbara OM-funktionen.