LETARAD

Tillbaka till alla funktioner

LETARAD är en Excel-funktion för att leta fram till data i en tabell som ordnats lodrätt. LETARAD kan använda sig av både ungefärlig och exakt matchning samt jokertecken (* ? ) för delvisa matchningar. Uppslagsvärden måste finnas i den kolumn längst till vänster i tabellen som används av LETARAD.

Ändamål

Hitta ett värde i en tabell genom att matcha till värden i första kolumnen

Returvärde

Det matchade värdet från en tabell.

Syntax

=LETARAD(letauppvärde;tabellmatris;kolumnindex;[ungefärlig])

Argument

letauppvärde – Värdet som ska sökas efter i kolumnen längst till vänster i en tabell.

tabellmatris – Tabellen där värdet ska hämtas från.

kolumnindex – Kolumnen i tabellen där värdet ska hämtas från.

ungefärlig – [valfritt] SANT = ungefärlig matchning (standard). FALSKT = exakt matchning.

Användningsanteckningar

LETARAD är en Excel-funktion som tillåter oss att hämta data från en tabell som ordnats lodrätt. Uppslagsvärden måste finnas i den kolumn längst till vänster i tabellen som används av LETARAD.  LETARAD kan använda sig av både ungefärlig och exakt matchning samt jokertecken (* ? ) för delvisa matchningar.

LETARAD tar in fyra argument: letauppvärde, tabellmatris, kolumnindex och ungefärlig. Letauppvärdet är värdet att leta efter, och tabellmatris är cellområdet där funktionen letar efter värdet. Tabellmatrisen första kolumnen måste innehålla uppslagsvärdena. Argumentet kolumnindex anses vara kolumnnumret för det värde som ska hämtas, där den första kolumnen i tabellmatrisen är kolumn 1. Slutligen kontrollerar argumentet ungefärlig matchningsbeteendet. Om ungefärlig är SANT eller 1 kommer LETARAD att utföra en ungefärlig matchning. Om ungefärlig är FALSKT eller noll kommer LETARAD att utföra en exakt matchning. Att använda argumentet ungefärlig är valfritt och är från början SANT, vilket betyder att LETARAD utför som standard en ungefärlig matchning.

Vertikal sökning

Syftet med LETARAD är att enkelt hitta information i en tabell:

Med ordernumret i kolumn C som letauppvärde kan LETARAD hämta KundID, Belopp, Namn och Stad för valfri ordning. Vill du till exempel hämta namnet på order 2005 är formeln:

=LETARAD(2005;C6:G10,4,FALSKT)

Returnerar ”Jan Svensson”

Vill du söka efter vågräta data kan du använda LETAKOLUMN, INDEX och PASSA eller XLETAUPP.

LETARAD är baserat på kolumnnummer

När du använder LETARAD, föreställ dig att varje kolumn i tabellmatrisen är numrerad, med början från vänster sida. Vill du hämta ett värde från en viss kolumn anger du det motsvarande numret som kolumnindex. I vårt exempel, kolumnindexet som hämtar förnamnet nedan är 2:

Genom att endast ändra värdet för kolumnindex kan du leta upp kolumnerna 2, 3 och 4:

=LETARAD(H2;B3:E12;2;FALSKT)

Letar upp förnamn

=LETARAD(H2;B3:E12;3;FALSKT

Letar upp efternamn

=LETARAD(H2;B3:E12;4;FALSKT)

Letar upp e-postadress

LETARAD letar endast åt höger

LETARAD kan bara leta efter värden från vänster till höger. Med andra ord kan man endast hämta data till höger om kolumnen som innehåller uppslagsvärden:

Vill du hitta värden till vänster kan du i stället använda dig av XLETAUPP eller INDEX och PASSA.

Matchningslägen

LETARAD har två lägen för matchning, exakt och ungefärlig, som styrs av det fjärde argumentet, ’ungefärlig’. När ’ungefärlig’ är SANT matchar LETARAD ett värdeintervall snarare än ett exakt värde. Ett bra exempel på detta är att använda LETARAD för att beräkna betyg. När ’ungefärlig’ är FALSKT utför LETARAD en exakt matchning, så som i exemplet ovan.

’Ungefärlig’ är ett valfritt argument, och är som standard SANT. Detta innebär att ungefärlig matchning är standardläge. Ställ in ’ungefärlig’ till att vara FALSKT för att genomföra en exakt matchning:

=LETARAD(värde;tabell;kolumnindex

Genomför en ungefärlig matchning (standard)

=LETARAD(värde;tabell;kolumnindex;SANT

Genomför en ungefärlig matchning

=LETARAD(värde;tabell;kolumnindex;FALSKT

Genomför en exakt matchning

Tips: Ange alltid ett värde för ’ungefärlig’ för att säkerställa det förväntade beteendet.

Du kan också ange noll (0) för en exakt matchning och 1 för ungefärlig matchning.

Exempel på exakt matchning

I de flesta fall kommer du förmodligen att använda LETARAD i det exakta matchningsläget. Detta är rimligt när du har ett unikt nyckeltal att använda som uppslagsvärde, till exempel KundID i denna tabell:

Endast första matchningen

När det kommer till duplicerade matchningsvärden hittar LETARAD den första matchningen. I exemplet nedan ska LETARAD-funktionen leta efter priset för färgen “Grön”. Det finns tre rader med färgen Grön, och LETARAD returnerar priset på den första raden den hittar. Formeln i cell F5 är:

=LETARAD(F5;C5:D11;2;FALSKT)

Returnerar 170 kr

Leta tvåriktat

I funktionen LETARAD hårdkodas normalt argumentet kolumnindex som ett statiskt tal. Du kan dock också skapa ett dynamiskt kolumnindex med hjälp av funktionen PASSA för att hitta den kolumn du vill hitta. Denna teknik hjälper dig skapa en dynamisk tvåvägsuppslagning som matchar på både rader och kolumner. I exemplet nedan är LETARAD gjort till att utföra en sökning baserat på namn och månad. Formeln i H6 är:

=LETARAD(I4;C5:F13;PASSA(I5;C4:F4;0);0)

Normalt sätt är INDEX och PASSA ett mer flexibelt sätt att utföra ett tvåriktat uppslag.

Flera villkor

Funktionen LETARAD hanterar inte flera villkor inom funktionen. Man kan dock använda en ’hjälpkolumn’ för att sammanfoga flera cellområden och använda dessa områden som om de vore flera villkor i en LETARAD-funktion. I exemplet nedan är kolumn C en hjälpkolumn som sammanfogar för- och efternamn tillsammans med den här formeln:

=D5&E5

Skapar hjälpkolumnen

LETARAD-funktionen är gjort för att göra samma sak för att skapa ett uppslagsvärde. Formeln i I6 är:

=LETARAD(I4&I5;C5:F13;4;0)

INDEX och PASSA samt XLETAUPP är bättre på att söka baserat på flera villkor.

LETARAD- och #SAKNAS!-fel

Använder du LETARAD kommer du oundvikligen att stöta på #SAKNAS!-felet. I exemplet nedan finns inte uppslagsvärdet ”Toy Story 2” i uppslagstabellen, och alla tre LETARAD-formlerna ger ett #SAKNAS!-fel:

Det #SAKNAS!-felet är användbart eftersom det berättar att något har gått fel. Anledningen till #SAKNAS! kan vara:

  • Uppslagsvärdet finns inte i tabellen
  • Uppslagsvärdet är felstavat eller innehåller extra mellanslag
  • Matchningsläget är exakt när det bör vara ungefärligt
  • Tabellområdet har inte angetts korrekt i funktionen
  • Du kopierar LETARAD-funktionen neråt och tabellreferensen är inte absolut

Vill du ”fånga” #SAKNAS!-felet och returnera ett annat värde kan du använda funktionen OMSAKNAS så här:

Formeln i H6 är:

=OMSAKNAS(LETARAD(I4;C5:F9;2;FALSE);”Hittades inte”)

Meddelandet som visas kan anpassas. Vill du att meddelandet ska vara tomt anger du tomma citattecken (””).

=OMSAKNAS(LETARAD(I4;C5:F9;2;FALSE);””)

Anteckningar

  • LETARAD utför som standard en ungefärlig matchning.
  • LETARAD är inte skiftlägeskänslig.
  • Argumentet ‘ungefärlig’ styr matchläget. FALSKT = exakt, SANT = ungefärligt (standard).
  • Om ’ungefärlig’ är tomt eller SANT eller 1:
    • LETARAD matchar det närmaste värdet mindre än letauppvärdet.
    • LETARAD använder fortfarande en exakt matchning om det är möjligt.
    • Kolumn 1 i tabellmatrisen behöver sorteras i stigande ordning.
  • Om ’ungefärlig’ är FALSKT eller noll:
    • LETARAD utför en exakt matchning.
    • Kolumn 1 i tabellmatrisen behöver inte sorteras.

I denna lektion kommer vi att gå igenom funktionen LETARAD.

Funktionen letar efter ett givet värde i kolumnen längst till vänster, och returnerar ett värde i en annan kolumn på samma rad.

Vi skriver in Lika med, LETARAD. Funktionen har fyra argument: det vi letar efter inom tabellen, som vi hittar i cell C4; cellområdet; hur många kolumner från vänster som vi hittar vårt returvärde, vilket för oss är den tredje; och SANT eller FALSKT beroende på om vi vill ha en exakt eller ungefärlig matchning, så vi skriver in FALSKT för exakt.

Vi gör sedan så att cellområdesreferensen är absolut, så att vi kan kopiera neråt och få fram resultaten för varje inköpsnummer.

I denna lektion har vi tagit en titt på LETARAD funktionen, som är användbar när man vill leta reda på vissa värden i en tabell.