januari 5, 2021
⭐️ Bemästra Excel’s PRODUKTSUMMA i 7 steg ⭐️

⭐️ Bemästra Excel’s PRODUKTSUMMA i 7 steg ⭐️

Vi har nu kommit till inlägget för funktionen PRODUKTSUMMA…min favoritfunktion. Jag stiftade bekantskap med denna funktionen för flera år sedan och hittar fortfarande nya sätt att använda den på. För en ekonom/statistiker eller logistiker så är denna funktion ovärdeligt att kunna pga sin mångsidighet. Från början var det nog inte meningen att funktionen skulle ha en så omfattande funktionalitet, men det blev ju bra…för oss!

Observera att ni finner en exempelfil för nedladdning längre ner i inlägget!

Se lektionen som lär dig funktionen PRODUKTSUMMA. Från Learnesys kurs Excelfunktioner Fördjupning

Just nu kan du använda rabattkoden cmkstiller i shoppen för -15% rabatt på alla Learnesys kurser!

Till vad använder man funktionen?

PRODUKTSUMMA rekommenderar jag till alla som sysslar med avancerad Excel då det är en ytterst användbar funktion och kan göra saker som flertalet andra funktioner kan såsom ELLER, ANTAL, LETARAD, SUMIFS, INDEX OCH MATCH. Genom att utforska vad denna funktion faktiskt klarar av så kommer man kunna spara otroligt mycket tid istället för att bearbeta data eller kombinera olika formler för att åstadkomma samma sak.

Jag använder denna funktion till följande arbete:

  • Resultatrapportering
  • Nyckeltalsberäkning
  • Preparera analytiska modeller

Hur formeln fungerar

Formeln är en summeringsformel där summeringsområdet kan ha flera kolumner eller flera rader. Jämför du med SUMMA.OMF så kan denna formel bara titta på tex en kolumn. Man kan kombinera funktionen med andra funktioner och jag kommer nedan visa hela 7 sätt hur jag använder formeln.

Exempel

1. Summering med undantag

Detta sätt använder jag absolut mest samt till resultatrapportering eller nyckeltalspresentationer.

Formeln går ut på att välja en rad eller kolumn i rådatan med faktorer som man sen matchar mot gruppkontona eller de andra faktorerna man har i rapporten såsom scenario samt månad i vårt fall nedan. Dessa faktorer refereras till som ”undantag”.

=PRODUKTSUMMA((Data!$A$5:$A$25=Report!$B6)*(Data!$C$3:$H$3=Report!C$4)*(Data!$C$4:$H$4=Report!C$5)*(Data!$C$5:$H$25))

De första tre delarna bearbetar faktorerna och den sista delen ”(Data!$C$5:$H$25)” definierar beloppens område nedan.

Notera att man kan även skriva in faktorn som man har i rapporten med text i formeln;

=PRODUKTSUMMA((Data!$A$5:$A$25=”Revenue”)*(Data!$C$3:$H$3=Report!C$4)*(Data!$C$4:$H$4=Report!C$5)*(Data!$C$5:$H$25))

Denna möjlighet används ofta i SUMIFS formler. I vårt fall ovan har vi låst på tex kolumn B för att slippa skriva in faktorernas benämningar för varje rad.

2. Summering med multiplicering

I exemplet nedan ser ni att vi även kan multiplicera pris med antal för att få intäktsvärdet. Jag har valt att bara ha ett undantag, dvs år 2019. Det formeln gör är att den multiplicerar rad för rad plus att den väljer summan för enbart år 2019. Denna variant använder jag till analytiska rapporter.

Om vi inte vill ha något undantag så blir formeln samma fast utan första parentesen:

3. Beräkna kvantitet

Denna variant kan likställas med SUMMA.OM, dvs vi summerar värden med ett undantag. Sättet använder jag vid snabba summeringar när vi snabbt behöver ha ett värde.

4. Beräkna unika värden

Exemplet nedan är en summerings-variant av ANTAL. Formeln tittar på hur många gånger som kund A samt kund B förekommer i datan. Dataområdet är kundkolumnen och undantaget är först kund A samt att man sen adderar samma för kund B. Varianten är av mer analytiskt art.

5. Beräkna snittpris

Här tittar vi på en beräkning av snittpris genom att först summera ihop alla prisbelopp för kund A samt B, för att sen dela med antalet unika värden för desamma enligt ovan beräkning. Även denna variant är användbar vid analytiskt arbete.

6. Summera största ordrar

I denna variant har vi gjort en, vad som på engelska kallas nested formula, och använt en formel i formeln. Här har vi börjat med PRODUKTSUMMA samt lagt till funktionen STÖRSTA och valt storleksnummer 1-3. Observera antalet parenteser om krävs samt hur de sitter. Varianten är något mer komplex och kan med fördel användas vid affärsanalys.

7. Beräkna intäkt med listfunktion

I denna sista variant av användbara funktioner med PRODUKTSUMMA har jag valt att visa hur man kan beräkna intäkten för olika kunder samt med valet att justera år och produkt i en filterlista. Vi har alltså gjort funktionen dynamisk och blandat in fler undantag och faktorer som påverkar resultatet vi får fram. Att arbeta med listfunktioner gör rapporter betydligt mer användbara och snygga vid presentationer.

De 3 första parenteserna definierar undantagen för; år produkt, kund och de sista två multiplicerar ihop pris samt kvantitet. Det tar tid att behärska denna typ av formel för multipla faktorer så det är bara att pröva sig fram samt hålla koll på var parenteserna ska sitta.

För att ni ska kunna testa ovan sätt att nyttja formeln så har jag valt att bifoga filen till ovan exempel nedan:

Övriga tips

Formeln har en begränsning till 255 matriser vilket jag tror räcker för de flesta. Observera att summaområdet behöver matcha lodrätt och vägrätt de undantag man inkluderar:

Nästa inlägg

I detta inlägg har jag gått igenom nyttan med den kraftfulla funktionen PRODUKTSUMMA och förklara vad den faktiskt kan göra samt hur jag använder den i arbetet.

Välkomna att connecta med mig på Linkedin samt gå in på Learnesys hemsida för mer information.

Carl Stiller i samarbete med Learnesy