Homepage Forum Excel sammanfoga (flytta värdet) i kolumner

Visar 2 svarstrådar
  • Författare
    Inlägg
    • #175665
      Sheberon
      Deltagare

      Hej

      Jag har 2 kolumner som det finns värden i, jag undrar hur jag enklast flyttar över värdet från den ena kolumnen till den andra.

       

    • #175845
      Niklas
      Keymaster

      Hej,

      Ett sätt kan vara att i – låt säga – C1 skriva en OM()-funktion. Se nedan:

      =OM(B1=””;A1;B1)

      Dvs – om B1 är tom; ge mig A1; annars B1.

      Något som kan vara ett problem är att Excel inte gillar tomma celler, utan kommer fylla de tomma cellerna med nollor.

      Om du inte vill ha nollorna, kan du istället skriva:

      =OM(OM(B1=””;A1;B1)=0;””;(OM(B1=””;A1;B1)))

      Dvs – om originalfunktionen är lika med 0; ge mig [blank cell]; annars ge mig originalfunktionen

       

      /Niklas på Learnesy

      • Det här svaret redigerades för 6 dagar, 8 timmar sedan av Niklas.
    • #177658
      Emil
      Keymaster

      Hej! Tror detta är det lättaste sättet:

      > markera kolumnen dit du vill hämta värden från andra kolumnen
      > klicka CTRL + G
      > Gå till special
      > Välj tomma celler
      > Ange värdet som ska hämtas in i formelfältet och klicka sedan CTRL + ENTER

Visar 2 svarstrådar
  • Du måste vara inloggad för att svara på detta ämne.