Want to get free access to our Excel functions course?

Fill in your e-mail address and telephone and we will give you 7 days free access to our course Excelfunksjoner Fordypning.

Del

Denne leksjonen leksjonen og mange andre kan du finne i vårt kurs Excelfunksjoner fordypning!

Sammendrag

SUMMERHVIS-funksjonen i Excel returnerer summen av celler som oppfyller ett visst vilkår. SUMMERHVIS kan brukes for å regne celler som inneholder datoer, tall og tekst. Vilkårene som brukes i SUMMERHVIS-funksjonen støtter logiske operatorer (>,<,<>,=) samt spesialtegn (*,?) for delvis samsvar.

Formål
Summere verdiene i cellene basert på en betingelse.

Argument
område – det området som vilkåret skal anvendes på
villkår – betingelsen som skal brukes
[summeringsområde] [valgfritt] ønsket område å summere. Hvis det utelates blir celleintervallet i det første argumentet summert.

Returverdi
Summen av de angitte verdiene.

Syntax
=SUMMERHVIS (område;vilkår;[summeringsmråde])


Hvordan bruke SUMMERHVIS-funksjonen i Excel?

Eksempel 1 – Grunnleggende bruk

Den generelle bruken av SUMMERHVIS er:

=SUMMERHVIS(celleområde;vilkår;[summeringsområde])

Vilkårene blir anvendt på cellene i området. Når cellene i området oppfyller vilkåret, blir tilsvarende celler i summeområdet summert. Argumentet summeområde er valgfritt – hvis du lar det være tomt, vil cellene angitt i område-argumentet bli summert i stedet.

Eksempel 2 – Grunnleggende eksempel

I eksempelet under har SUMMERHVIS-funksjonen blitt brukt for å samle totalbeløpene per kunde. Formelen i celle G5 er:

=SUMMERHVIS($C$5:$C$22;F5;$D$5:$D$22)
Bildet viser funksjonen SUMMERHVIS i excel
Eksempel 2: SUMMERHVIS i sin enkleste utførelse. Her bruker SUMMERHVIS-funksjonen alle tre argumentene. Ved å bruke SUMMERHVIS-funksjonen kan man få informasjon om den totale ordreverdien per kunde.

Legg merke til at likhetstegnet (=) ikke er nødvendig når du oppretter “er lik” betingelser. Merk også at cellehenvisningen F5 brukes som det andre argumentet. Det er like gyldig å bruke verdien innenfor anførselstegn (“”). I dette tilfellet blir det imidlertid vanskelig å erstatte cellehenvisningen med en verdi, da verdien må endres når funksjonen fylles nedover.

Eksempel 3 – Større enn & vilkår i en annen celle

I dette eksempelet summeres større ordre som overstiger beløpet 2000 kr. Her brukes cellen G6 som vilkår i det andre argumentet.

Bildet viser funksjonen SUMMERHVIS i excel
Eksempel 3: brukes operatoren “>” som vilkår, sammen med cellen direkte over cellen inneholder funksjonen.

Eksempel 4 – Ikke lik med

Hvis du ønsker å uttrykke vilkår for “ikke lik med” i en formel, bruker du operatøren “<>” innenfor anførselstegn (“”):

=SUMMERHVIS(E6:E20;"<>Hentet")
Bildet viser funksjonen SUMMERHVIS i excel
Eksempel 4: har brukt operatoren ikke lik med (“<>”) for å se hva totalbeløpet er for de ordrene som er hentet.

Eksempel 5 – tomme celler

SUMMERHVIS kan beregne summer basert på tomme elller fylte celler. Eksempel:

=SUMMERHVIS($C$5:$C$22;"";$D$5:$D$22)

summerer om cellen er tom,

=SUMMERHVIS($C$5:$C$22;"<>";$D$5:$D$22)

summerer om cellen ikke er tom.

Eksempel 6 – Dato

Den letteste måten å bruke SUMMERHVIS med datoer er å sette inn en referanse til en gyldig dato i en annen celle, eller bruke DATO-funksjonen. Eksempelet nedenfor viser begge disse metodene.

=SUMMERHVIS($C$5:$C$22;">"&DATO(2023;03;01);$D$5:$D$22)

Over bruker vi funksjonen DATO og den logiske operatoren “&”. Nedenfor er tanken at DATO-funksjonen er erstatter en cellehenvisning på en enkel måte:

=SUMMERHVIS($C$5:$C$22;">"&G6;$D$5:$D$22)

Mer om funksjonen SUMMERHVIS

SUMMERHVIS-funksjonen returnerer summen av celler i et område som oppfyller en enkelt vilkår. Det første argumentet er området der vilkåret som skal anvendes, det andre argumentet er selve vilkåret, og det siste argumentet er området som inneholder verdiene som skal summeres. SUMMERHVIS støtter logiske operatorer (>,<,<>,=) og såkalte spesialtegn (* og ?) for delvis samsvar.

SUMMERHVIS er en av åtte funksjoner i Excel som deler opp logiske betingelser i to deler (celleområde + vilkår). Derfor er syntaksen som brukes for å opprette betingelser annerledes, og SUMMERHVIS krever et område av celler. Du kan derfor ikke bruke en matrise.

SUMMERHVIS kan bare bruke én enkelt betingelse. Hvis du trenger å bruke flere betingelser, kan du i stedet bruke funksjonen SUMMER.HVIS.SETT. Hvis du trenger å endre verdier i argumentet for celleområdet som en del av en logisk test, kan du bruke funksjonene SUMMERPRODUKT eller FILTRER.

Nyttig å vite om SUMMERHVIS-funksjonen

  • SUMMERHVIS kan bare bruke én betingelse. Bruk funksjonen SUMMER.HVIS.SETT for å bruke flere vilkår.
  • SUMMERHVIS er ikke følsom for storebokstaver. Funksjonen skiller for eksempel ikke mellom “hentet”, “HENTET” og “Hentet”.
  • Når summeområdet utelates, blir cellene i celleområdet i det første argumentet summert i stedet.
  • Tekststrenger i betingelsene må være innenfor anførselstegn (“”), for eksempel “økonomiavdelingen”, “>1500”), osv.
  • Cellereferanser i betingelsene skal ikke være innenfor anførselstegn.
  • SUMMERHVIS krever et celleområde- du kan ikke bruke en matrise.

Mer Lesing

Du kan lære mer om SUMMERHVIS-funksjonen i våre kurs Excel Basis og Excelfunksjoner fordypning!

SUMMERHVIS-funksjonen summerer verdiene i et celleområde, som oppfyller et visst vilkår.
I eksemplet ønsker vi kun å summere de tallene med høyere verdi enn 10.
Dette krever to argumenter: celleområdet… og vilkåret, «større enn 10» i anførselstegn.

Som vi ser så er summen av tallene høyere enn ti, hundre og tre.
I denne leksjonen har vi vist funksjonen som summerer verdiene i et celleområde basert på et vilkår, SUMMERHVIS